Actualizar a Moodle 3.9

Requisitos previos

  • Esta guía es válida para actualizar desde versiones 3.2 hacia delante.
  • Se necesita una versión mínima de PHP 7.0.0 (con extensión intl)

Puedes revisar las versiones de php disponibles desde la terminal con:

find / -name php -type f
# Salida:
/opt/plesk/php/7.3/bin/php
/opt/plesk/php/7.1/bin/php
/opt/plesk/php/7.4/bin/php
/opt/plesk/php/7.2/bin/php
/opt/plesk/php/7.0/bin/php

Otra opción es crear un archivo con el siguiente codigo php y visualizarlo desde navegador:

<?php
echo 'Current PHP version: ' . phpversion();
?>

más info en:

https://www.wikihow.com/Check-PHP-Version

  • Versión de MariaDB 10.2.29

Puedes revisar tu versión de MariaDB con mysql -V

mysql -V
# Salida:
mysql  Ver 15.1 Distrib 10.2.33-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

Pasos a seguir

  1. Copiar los archivos del antiguo Moodle a otra ubicación, estos deberían estar en la carpeta raíz del dominio. Por ejemplo, creando una carpeta moodle_old y moviendo los archivos aquí.
    Podremos guardar estos archivos a modo de backup.
    Nota: No confundir con la carpeta moodledata
  2. Descargamos la última versión de moodle desde: https://download.moodle.org/
    Subimos el archivo a la carpeta raíz, donde antes estaban los archivos de la antigua versión, y la descomprimimos.
  3. Copiamos el archivo config.php de la carpeta moodle_old al directorio de Moodle actual.
  4. Si tenías instalados plugins o themes adicionales, cópialos también.
    La carpeta de temas se encuentra en moodle_old/theme.
  5. Ahora accedemos a la aplicación como administrador. Nos pedirá la clave de actualización, que se encuentra en el fichero config.php:
    $CFG->upgradekey = ‘KnwQ9KNv0Eee0AK3dAmb’;

Nos aparecerá una pantalla donde si cumplimos todo los requisitos podremos finalizar la actualización.


Fuente:

https://docs.moodle.org/all/es/38/Actualizaci%C3%B3n_de_moodle#Paquete_de_instalaci.C3.B3n_est.C3.A1ndar

Deja una respuesta